macのvimでtopcoder

EclipseCoderがjunoで使えない悲劇に直面。

ならmacでもVimCoder.jarを使うしか無いじゃないか!!

 

$ brew install macvim

$ vim ~/.vimrc

NeoBundle 'acx0/vimcoder'

$ vim

:NeoBundleInstall

$ cd ~/.vim/bundle/vimcoder

$ make

$ make jar

あとはdlしていたTopCoderアプレットからEditorの設定をするんだけど、ClassPathは ~/.vim/bundle/vimcoder/VimCoder-0.3.2.jarで。

そして options -> Editor -> さっきの設定内容を選択 -> configure

vim command : /usr/local/bin/macvim

こんな感じで設定して、ContestAppletProd.jnlpからTopCoderアプレットを起動して問題を選択してやるとmacvimが起動してくれてる